全站数据
8 4 2 0 5 8 1

那个LDF文件超大,怎么办

IT科技先知道 | 简单学习,快乐成才!         
问题更新日期:2024-10-12 10:01:12

问题描述

那个LDF文件超大,怎么办希望能解答下
精选答案
最佳答案

LDF文件太大,下面以SQL2005 为利讲解解决方案:请按步骤进行,未进行前面的步骤,请不要做后面的步骤 否则可能损坏你的数据库。

1、清空日志: DUMPTRANSACTION库名WITH NO_LOG

2、截断事务日志: BACKUPLOG库名WITH NO_LOG

3、收缩数据库文件(如果不压缩,数据库的文件不会减小): 服务器——右键你要压缩的数据库——所有任务——收缩数据库——收缩文件 ——选择日志文件——在收缩操作里选择在释放未使用的空间前重新组织页,这里会给出一个允许收缩到的最小M数,确定就可以了 ——选择数据文件——在收缩操作里选择在释放未使用的空间前重新组织页,这里会给出一个允许收缩到的最小M数,确定就可以了 也可以用SQL语句来完成 ——收缩数据库 DBCC SHRINKDATABASE(库名) ——收缩指定数据文件,1是文件号,可以通过这个语句查询到:select * from sysfiles DBCC SHRINKFILE(1)

4、为了最大化的缩小日志文件:a、分离数据库: 服务器——数据库——右键——分离数据库 b、在我的电脑中删除LOG文件 c、附加数据库: 服务器——数据库——右键——附加数据库 此法将生成新的LOG,大小只有500多K

5、为了以后能自动收缩,做如下设置: 服务器——右键数据库——属性——选项——选择

"自动收缩

"

6、如果想以后不让它日志增长得太大: 服务器——右键数据库——属性——文件——数据库文件——日志——增量为10%,不限制增长 ——将文件增长限制为xM(x是你允许的最大数据文件大小) 注意:一般不建议做第4,6两步 第4步不安全,有可能损坏数据库或丢失数据 第6步如果日志达到上限,则以后的数据库处理会失败,在清理日志后才能恢复。